PubMed and NCBI Browser Requirements

As of 1/1/13, PubMed and other NCBI web pages will not support older versions of Internet Explorer and Firefox, as follows:

NCBI will no longer support Internet Explorer 7.0 as of January 1, 2013
NCBI will no longer support Firefox 3.0 as of January 1, 2013

Visit http://www.ncbi.nlm.nih.gov/guide/browsers to learn more about browser requirements.

Comments are closed.